版本问题

springboot 1.x

server.context-path=/demo

springboot 2.x

server.servlet.context-path=/demo
不兼容了许多组建:sleuth.

1.5的springboot 对各大开源组件兼容的版本比较低 比如es、

因项目中使用es。5.X、spring-boot1.5兼容到4.X版本

而springboot对es5.x的兼容是spring-boot2.0版本、干的项目里前后不能相顾、很尴尬。。